• Chris Trainer
    Participant
    Post count: 6
    • Offline
    #539 |

    Hi my A901 now only works on one speed and briefly there was a slight smell of burning, the smell dissipated quite quickly but the mixer still only runs at one speed.
    I have two questions really, will this Repair Kit mend the mixer and exactly how difficult is this repair kit to install, I don’t want to start this and end up with more parts and wires than I can keep a track of and not be able to finish it

    thanks

    Chris

  • tech support
    Keymaster
    Post count: 46
    • Offline
    #540 |

    Hi Chris,

    this is an entry level kit and requires only the most basic of skills to successfully complete and there is only light disassembly involved, the whole process should take no longer than 30 minutes or so from start to finish. If you start the repair and feel unsure of how to proceed at any time just post here and we will walk you through the process step by step until you complete the repair,

    regards,

    George

  • Chris Trainer
    Participant
    Post count: 6
    • Offline
    #1280 |

    Hi Tech Support,

    thanks for the reassurances, I’ve fitted your Repair Kit, and the Mixer now runs as good as new, Installation was as easy as you suggested and I needed no more support than was included in the kit instructions, really happy not to have to replace the Mixer as I have no real confidence in the quality of the Mixers available these days these old Kenwood Mixers really take some beating,

    thanks again,

    Chris

  • tech support
    Keymaster
    Post count: 46
    • Offline
    #1281 |

    Hi Chris,

    Congratulations on your Successful Repair, every repair is supported and reinforced by the care and diligence employed in its installation, well done ! and thank you for posting your success it will reassure and inspire future Repair Kit Installers,

    kind regards,

    George

You must be logged in to reply to this topic.